
 
 
 
 
 
 
 

 
 
 

VoiceQ Pro: REAPER User Guide



VoiceQ Pro 1 

REAPER User Guide 1 

VoiceQ and Digital Audio Workstations 3 

About Reaper 4 

Feature Highlights 4 

DAW Preferences (VoiceQ) 5 

Rewire Setup 6 

Single Machine Setup (using IAC driver) 7 

Basic MIDI setup in VOICEQ 8 

Basic MIDI setup in REAPER 9 

VoiceQMIDISync plugin 11 

Dual Machine Setup (using Network driver) 12 

Mac running Reaper 12 

Mac running VoiceQ 15 



VoiceQ and Digital Audio Workstations 

This guide describes the configurations and procedures used within VoiceQ and Digital Audio 
Workstations and is intended for use by Audio Engineers to understand the operation and 
configuration of both systems. 

 
During the recording process, VoiceQ takes over the role of playing back the media file. You can 
leave the media file loaded in your Reaper session, but the track should be disabled, to avoid 
competing with the VoiceQ Application. 

 
VoiceQ superimposes the scrolling text on the media and outputs it via the second DVI port of your 
Apple Mac video card (or the external DVI port on laptops). VoiceQ uses the Graphics Processing 
Unit (GPU) and the Memory on the video card to process the video, which reduces the load on the 
CPU of your computer. 

 
VoiceQ will chase and scrub with Reaper while you work in Reaper. VoiceQ also has an option to 
cue Reaper when you select a line in VoiceQ. This will locate the Reaper session to the record 
location for the selected line with an adjustable pre-roll value. 

Recent improvements specific to VoiceQ Pro: 

• GENMTC Support for accurate sync 
• VoiceQ listens for ‘Start, Continue, Play & Stop commands’ 

• Latency Compensate – Is now redundant with GENMTC active. We have left it in as a feature 
for hardware that may have trouble performing under load. 

• Post-roll – Users can set post-roll in VoiceQ Preferences 
• Mute Sound when Recording – mutes VoiceQ audio when recording 
• Recording starts before a set time (See Preferences) 

• Recording Icon added to VoiceQ Transport Actual recording of audio and management of 
playlists still takes place in Reaper using your normal process. 

 
Note: In a single computer configuration VoiceQ will work with many other recording applications 
including Logic Pro and others. Check our website for the correct setup instructions and 
screenshots for these applications. 

 
Note: In a dual computer configuration the Digital Audio Workstation may be any device that will 
output MIDI Time Code (MTC) and/or MIDI Machine Control. 



About Reaper 
 
 

Using REAPER with your Mac, and no other software, you can import any audio and MIDI, 
synthesize, sample, compose, arrange, edit, mix, and master songs or any other audio projects. 
If you add a hardware audio interface and a microphone, you have a complete professional quality 
recording studio, suitable for recording anything from a soloist to a band to an orchestra. 

 
The best way to understand what REAPER can do is to try it for yourself. There is only one version 
of REAPER, used by home hobbyists and high-end professional studios alike. Evaluate the full 
version of REAPER with no obligation for up to 60 days. 

The free User Guide and helpful user forum are always available if you need a hand. 

Feature Highlights 

• Efficient, fast to load, and tightly coded. Can be installed and run from a portable or network 
drive. 

• Powerful audio and MIDI routing with multichannel support throughout. 

• 64-bit internal audio processing. Import, record to, and render to many media formats, at 
almost any bit depth and sample rate. 

• Thorough MIDI hardware and software support. 

• Support for thousands of third-party plug-in effects and virtual instruments, including VST, 
VST3, AU, DX, and JS. 

• Hundreds of studio-quality effects for processing audio and MIDI, and built-in tools for creating 
new effects. 

• Automation, modulation, grouping, VCA, surround, macros, OSC, scripting, control surfaces, 
custom skins and layouts. 

• A whole lot more. 



DAW Preferences (VoiceQ) 

The preferences have been slightly altered to allow easier user access to options for MIDI. 
 

 

MIDI/Rewire Option Selection – Allows users to select either MIDI or ReWire connections. Note: 
ReWire will not be visible if not active or installed. 

 
Output MMC Port Checkbox – Outputs MIDI/ReWire data and ignores any chase data sent from 
Reaper. This option is used if Reaper engineers need to make changes on the fly and not affect 
VoiceQ playback. 

 

MIDI Selection – This dropdown lists all available external connections 
 
Latency Compensate – If playback is incorrect between VoiceQ and the set DAW. Users can 
adjust the latency using the slider. 

 
Pre-Roll – Users can now set pre-roll in Reaper and leave this option unchecked. This option is 
available if users wish to see pre-roll when not connected to a DAW 

 

Post-Roll – Sets the time the DAW records after the line is completed 

Mute Sound when recording – Mutes VoiceQ audio 

Recording Starts before – Sets the time the DAW records before the line begins. 

Insertion follows playback - Playhead follows from DAW in VoiceQ 
 
Synchronisation - User can select either to output ‘MIDI Timecode (MTC)’ or ‘Song Position 
Pointer (SPP)’ 

 
Scrubbing - Scrubbing allows users to choose the send interval 



Rewire Setup 

1. Install Rewire (see installing rewire) 
2. Open Reaper 

3. Select ‘Track>Insert new track…’ 
 

 

4. Select ‘FX’ on the track head and select ‘Add” then select ‘ReWire: VoiceQ ReWire 
Device’ (note: If VoiceQ Rewire Plug-in is not visible please refer to the ReWire FAQ) 

 

 

5. Launch VoiceQ and a project you wish to connect and select 
‘VoiceQ>Preferences>Global>DAW’ from VoiceQ main menu. 

6. Here you will select ReWire as you primary sync option 
 

 
7. Close the Preferences window and select the Chase external timecode option on the toolbar 

(command+J) 



Single Machine Setup (using IAC driver) 

The Apple Inter Application Communication (IAC) Bus is used to send all MIDI information when 
VoiceQ and Reaper are on the same computer – we refer to this as a Single Computer 
Configuration. A MIDI interface or Network Session is used when the Digital Audio Workstation 
(DAW), in this case Reaper, and VoiceQ are on separate machines (dual computer configuration).  
If you are using a Dual Computer Configuration you do not need the IAC Bus and can skip directly 
to the next section. 

 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. Launch this app 
and select Window>Show MIDI Window (Command + 2) from the menu to open it. 

 

 
2. Select IAC Driver. Double click it to open the IAC Driver Properties window. 

 

3. Add Ports by selecting ‘+’ button and give the port a name. In this example, we named it 
VoiceQ MMC/MTC. 

 

4. Click the checkbox ‘Device is online’ to enable this virtual MIDI device. 



Basic MIDI setup in VOICEQ 

5. Launch VoiceQ and select ‘VoiceQ>Preferences>Global>DAW’ from VoiceQ main menu. 
6. Enable Output MMC Port and select the IAC Driver by name. 

7. Select ‘Song Position Pointer (SPP)’ from the Synchronization in order for Reaper to read the 
timing and sync correctly. 

 

 

8. Close the Preferences window and select the Chase external timecode option on the toolbar 
(command+J) 

 



Basic MIDI setup in REAPER 

Note: your MIDI input and output devices are setup in the Options → Preferences MIDI Devices 
pull down. You need to configure Reaper first, if you have not done so. 

 

 

Please download the following file to see the connection settings already prepped: 

Reaper demo - DOWNLOAD 
 

1. Open Reaper and Right Click in the track pane (on the left) to create a new track. Or you can 
use the Control-T hotkey combination. 

 

 
2. Click the Record icon (red circle) box on the left. This arms the track for recording. It will also 
turn red. 

 

3. Click the speaker icon, it will turn solid white. This will send your MIDI controller output to the 
selected MIDI output. 

 



4. Select the Input selection dropdown. The Input selection defaults to Analog 1. We want MIDI 
input, so click on that area and select MIDI Input and the desired input device. You then want to 
select 'All Channels’ as an option. 

 

5. Click on Routing button. 

6. Under – MIDI Hardware Output – select your MIDI output device. You can leave the default 
Send to Original Channels selected. 

 

 

7. Right click the Play icon and select “SPP: All inputs’ 
 

 
8. Follow the instructions below to add the VoiceQMIDISync plugin to complete the set-up. 



VoiceQMIDISync plugin 

VoiceQMIDISync.js 

Download 

Users can download the effect and add this to your reaper plugin folder “User/Library/ 
Application Support/REAPER/Effects/“ 

Alternatively the user can add the plug-in via the FX panel following the steps below. 

Steps: 

1. Open FX – ‘Add’ right click and ‘Create new JS FX’ 
2. Name it ‘VoiceQMIDISync’ 
3. Select ‘Edit’ 
4. The following screen will open – this is where we will post our code. 
5. Open ‘VoiceQMIDISync.js’ file and copy all the text. 
6. Now go back to Reaper and the opened FX editor. 
7. Select all of the code and paste the new code from the js file. 
8. You should now have a working FX file. 

 



Dual Machine Setup (using Network driver) 

Reaper connection via Network is currently unstable, we are looking for feedback from 
users who can execute a stable network connection. We will update the guide when we have 
more information for our users on using a multi-computer connection. 

 

The Dual Computer Configuration is when Reaper and VoiceQ are on separate computers with 
MIDI information sent via the Local Area Network (LAN) or WiFi. 

 
With a Dual Computer Configuration, we can use Apple’s MIDI network feature to send MIDI via 
the Local Area Network. This setup does not require any additional MIDI hardware. First configure 
your LAN (if required) so the 2 machines can communicate and ‘see’ each other on the local 
network. Contact your Systems Administrator for assistance if required. 

 

Mac running Reaper 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. Launch this app 
and select Window>Show MIDI Window (Command + 2) from the menu to open it. 

 

2. Select Network. Double click it to open the MIDI Network Setup window. (MacOS Mohave 
users: the network settings are now located on the top toolbar) 

 

 
3. Add a session by selecting ‘+’ button under My Sessions. Enable the session by clicking the 

Enabled check box under Session and name it. We are using the default name ‘Session 1’ in 
this example. 

4. Select ‘Anyone’ from the drop down list under ‘Who may connect to me:’ section. 
5. Select this Network Session from the first drop down list under the ‘Live routings’ section. 

(Note skip this if you have lag or connectivity issues) 



 

Note: your MIDI input and output devices are setup in the Options → Preferences MIDI Devices 
pull down. You need to configure Reaper first, if you have not done so. 

 

 

Please download the following file to see the connection settings already prepped: 

Reaper demo - DOWNLOAD 
 

6. Open Reaper and Right Click in the track pane (on the left) to create a new track. Or you can 
use the Control-T hotkey combination. 

 

 
7. Click the Record icon (red circle) box on the left. This arms the track for recording. It will also 
turn red. 
8. Click the speaker icon, it will turn solid white. This will send your MIDI controller output to the 
selected MIDI output. 

 

 

9. Select the Input selection dropdown. The Input selection defaults to Analog 1. We want MIDI 
input, so click on that area and select MIDI Input and the desired input device. You then want to 
select 'All Channels’ as an option. 



 
 

10. Click on Routing button. 

11. Under – MIDI Hardware Output – select your Network MIDI output device. You can leave the 
default Send to Original Channels selected. 

 

 

12. Right click the Play icon and select “SPP: All inputs’ 
 

 

13. Follow the instructions below to add the VoiceQMIDISync plugin to complete the set-up. 



Mac running VoiceQ 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. Launch this app 
and select Window>Show MIDI Window (Command + 2) from the menu to open it. 

 

 

2. Select Network. Double click it to open the MIDI Network Setup window. (MacOS Mohave 
users: the network settings are now located on the top toolbar) 

 

3. Add a session by selecting ‘+’ button under My Sessions. Enable the session by clicking 
theEnabled check box under Session. You must give the exactly same name and port used in 
Step 3. Again, we are using the default name ‘Session 1’ in this example. 

4. Now you can see the Mac runs Reaper from the Directory list. In our example, its name is 
Yosemite iMac. Select the Mac runs Reaper from the list. Connect to it by clicking the 
‘Connect’ button. 

5. Launch VoiceQ and select VoiceQ>Preferences… from VoiceQ main menu. 

6. Enable Output MMC Port and select the Network session by name. In this example it is 
Session 1. 

 

7. Select the MIDI Chase Icon in the lower left hand corner of the VoiceQ Project window. 
 



Note: RTC-MIDI protocol used for this configuration is stable in most cases but it does not 
guarantee zero packet loss. The latency and the possibility of packet loss may vary under your 
network conditions. Especially when the network is congested, which may cause the latency and 
packet loss to increase. 
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