
 

 

 

 
 

 
 
 
 
 
 
 
 

 

 
 
 

 
 

 

VoiceQ Pro & Pro Tools 
Integration: User Guide 

 
 

  



2 

 

 

VoiceQ and Digital Audio Workstations 

This guide describes the configurations and procedures used 
within VoiceQ and Digital Audio Workstations and are intended for 
use by Audio Engineers to understand the operation and 
configuration of both systems. 

During the recording process VoiceQ takes over the role of playing back the 
movie file from Pro Tools. You can leave the movie file loaded in your Pro 
Tools session, but the track should be disabled, to avoid competing with the 
VoiceQ Application. 

VoiceQ superimposes the scrolling text on the movie and outputs it via the 
second DVI port of your Apple Mac video card (or the external DVI port on 
laptops). VoiceQ uses the Graphics Processing Unit (GPU) and the Memory 
on the video card to process the video, which reduces the load on the CPU 
of your computer. 

VoiceQ will chase and scrub with Pro Tools while you work in Pro Tools. 
VoiceQ also has an option to cue Pro Tools when you select a line in VoiceQ. 
This will locate the Pro Tools session to the record location for the selected 
line with an adjustable pre-roll value. 

Recent improvements specific to VoiceQ Pro: 

 GENMTC Support for accurate sync 

 VoiceQ listens for ‘Start, Continue, Play & Stop commands’ 

 Latency Compensate – Is now redundant with GENMTC active. We 
have left it in as a feature for hardware that may have trouble 
performing under load. 

 Postroll – Users can set post-roll in VoiceQ Preferences 

 Mute Sound when Recording – mutes VoiceQ audio when recording 

 Recording starts before a set time (See Preferences) 

 Recording Icon added to VoiceQ Transport 

Actual recording of audio and management of playlists still takes place in Pro 
Tools using your normal process. 

Note: In a single computer configuration VoiceQ will work with many other 
recording applications including Logic Pro and others. Check our website for 
the correct set up instructions and screen shots for these applications. 

Note: In a dual computer configuration the Digital Audio Workstation may be 
any device that will output MIDI Time Code (MTC) and/or MIDI Machine 
Control. 
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DAW Preferences 
 

The preferences have been slightly altered to allow easier user access to 

options for MIDI. 

 

MIDI/Rewire Option Selection – Allows users to select either MIDI or 

ReWire connections. Note: ReWire will not be visible if not active or installed. 

 

Output MMC Port Checkbox – Outputs MIDI/ReWire data and ignores any 

chase data sent from Pro Tools. This option is used if Pro Tools engineers 

need to make changes on the fly and not affect VoiceQ playback. 

 
MIDI Selection – This dropdown lists all available external connections 

 
Latency Compensate – If playback is incorrect between VoiceQ and the set 

DAW. Users can adjust the latency using the slider. 

 
Pre-Roll – Users can now set pre-roll in Pro Tools and leave this option 

unchecked. This option is available if users wish to see pre-roll when not 

connected to a DAW 

 

Postroll – Sets the time the DAW records after the line is completed 

 
Mute Sound when recording – Mutes VoiceQ audio 

 
Recording Starts before – Sets the time the DAW records before the line 

begins. 
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Single Machine Setup (using IAC driver) 

The Apple Inter Application Communication (IAC) Bus is used to send all MIDI 
information when VoiceQ and Pro Tools are on the same computer – we refer 
to this as a Single Computer Configuration. 

A MIDI interface or Network Session is used when the Digital Audio 
Workstation (DAW), in this case Pro Tools, and VoiceQ are on separate 
machines (dual computer configuration). If you are using a Dual Computer 
Configuration you do not need the IAC Bus and can skip directly to the next 
section. 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI 
Setup.app. Launch this app and select Window>Show MIDI Window 
(Command + 2) from the menu to open it. 

 

 
2. Select IAC Driver. Double click it to open the IAC Driver Properties 

window. 
 

 
3. Add Ports by selecting ‘+’ button and give the port a name. In this 

example, we named it VoiceQ MMC/MTC. 

4. Click the checkbox ‘Device is online’ to enable this virtual MIDI 
device. 
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5. Launch Pro Tools application and select Pro Tools>Preferences… 

from the menu. 

6. Go to Synchronization tab and check both ‘Machine Chases 
Memory Location’ and ‘Machine Follows Edit Insertion/Scrub’ 
checkboxes. 

 

 

7. Select Setup>Peripherals… from the menu to open the peripherals 
setup window. 

8. Go to Synchronization tab and Select the IAC Driver added in Step 
3 for MTC Reader and Generator ports. In this example, it is named: 
IAC Driver, VQ & PT. 

 

 

9. Go to Machine Control tab and enable both Master and Slave, 
select the IAC Driver under the Master, and give the Master’s ID = 
120 so as not to cause a conflict when you Set ID of the Slave to 127. 

 

 

10. Select Setup>MIDI>MIDI Beat Clock… from the Pro Tools main menu 
to open the MIDI Beat Clock window. Enable MIDI Beat Clock and 
select the IAC Driver. 
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11. In the Transport window or Synchronizations options via transport, 
select ‘GEN MTC’. 

 

 
12. Launch VoiceQ and select VoiceQ>Preferences… from VoiceQ 

main menu. 
 

 

13. Enable Output MMC Port and select the IAC Driver by name. In this 

example it is VoiceQ MMC.MTC. 

14. Select the MIDI Chase Icon in the lower left hand corner of the VoiceQ 

Project window. 

 

 
VoiceQ and Pro Tools are now ready to communicate through a 

virtual MIDI device. 



7 

 

 

 

Dual Machine Setup using Network (RTC-MIDI) 

The Dual Computer Configuration is when Pro Tools and VoiceQ are on 
separate computers with MIDI information sent via the Local Area Network 
(LAN). 

With a Dual Computer Configuration, we can use Apple’s MIDI network 
feature to send MIDI via the Local Area Network. This setup does not require 
any additional MIDI hardware. First configure your LAN (if required) so the 2 
machines can communicate and ‘see’ each other on the local network. 
Contact your Systems Administrator for assistance if required. 

 

On the Mac running Pro Tools 
 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI 
Setup.app. Launch this app and select Window>Show MIDI Window 
(Command + 2) from the menu to open it. 

 

 
2. Select Network. Double click it to open the MIDI Network Setup 

window. 
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3. Add a session by selecting ‘+’ button under My Sessions. Enable the 
session by clicking the Enabled check box under Session and name it. 
We are using the default name ‘Session 1’ in this example. 

4. Select ‘Anyone’ from the drop down list under ‘Who may connect to 
me:’ section. 

5. Select this Network Session from the first drop down list under the 
‘Live routings’ section. 

 

On the Mac running VoiceQ 
 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI 
Setup.app. Launch this app and select Window>Show MIDI Window 
(Command + 2) from the menu to open it. 

 

 
2. Select Network. Double click it to open the MIDI Network Setup 

window. 
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3. Add a session by selecting ‘+’ button under My Sessions. Enable the 
session by clicking the Enabled check box under Session. You must 
give the exactly same name and port used in Step 3. Again, we are 
using the default name ‘Session 1’ in this example. 

4. Now you can see the Mac runs Pro Tools from the Directory list. In our 
example, its name is Yosemite iMac. Select the Mac runs Pro Tools 
from the list. Connect to it by clicking the ‘Connect’ button. 

 

On the Mac running Pro Tools 
 

1. Launch Pro Tools application and select Pro Tools>Preferences… 

from the menu. 

2. Go to ‘Synchronization’ tab and check both ‘Machine Chases 
Memory Location’ and ‘Machine Follows Edit Insertion/Scrub’ 
checkboxes. 

 

 

3. Select Setup>Peripherals… from the menu to open the peripherals 
setup window. 

4. Go to ‘Synchronization’ tab and Select the Network port for both 
MTC Reader and Generator ports. In this example, it is Network, 
Session 1. 

 

 

5. Go to Machine Control tab and enable both Master and Slave: 
select the IAC Driver under the Master, and give the Master’s ID = 
120 so as not to cause a conflict when you Set ID of the Slave to 127. 
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6. Select Setup>MIDI>MIDI Beat Clock… from the Pro Tools main menu 
to open the MIDI Beat Clock window. Enable MIDI Beat Clock and 
select the Network port. 

 

 

7. In the Transport window or Synchronizations options via transport, 
select ‘GEN MTC’. Once activated both PT and VQ will be in sync. 
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On the Mac running VoiceQ 
 

1. Launch VoiceQ and select VoiceQ>Preferences… from VoiceQ 
main menu. 

 

 
2. Enable Output MMC Port and select the Network session by name. 

In this example it is Session 1. 

3. Select the MIDI Chase Icon in the lower left hand corner of the VoiceQ 

Project window. 

 

 

VoiceQ and Pro Tools are now ready to communicate through your 
network (RTC-MIDI). 

 

Note: RTC-MIDI protocol used for this configuration is stable in most cases 

but it does not guarantee zero packet loss. The latency and the possibility of 

packet loss may vary under your network conditions. Especially when the 

network is congested, which may cause the latency and packet loss to 

increase. 
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Dual Machine Setup using MIDI hardware interfaces 

Using separate computers for Pro Tools and VoiceQ with MIDI information 
sent via MIDI hardware interfaces. 

This configuration requires a MIDI hardware interface on both computers, 
which are connected via a MIDI cable. Many AVID hardware boxes like the 
M-Box, Digi 001-003, Command 8, Control 24 feature MIDI output ports. 

The VoiceQ computer can use any standard USB MIDI interface, with VoiceQ 
automatically recognizing and chasing incoming MIDI timecode when it is set 
to online/chase mode. 

 

On both Macs running Pro Tools and VoiceQ 
 

1. Connect both computers with the MIDI Device using the appropriate 
MIDI cables. The actual configuration maybe different from the screen 
shots. 

2. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI 
Setup.app. Launch this app and select Window>Show MIDI Window 
(Command + 2) from the menu to open it. 
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3. Check all your MIDI interfaces are shown in the windows of both 
machines. If not, click `Rescan MIDI’ button to rescan MIDI ports. In 
this example, we used USB MS1x1 MIDI Interface from M-Audio for 
Pro Tools machine, and USB Uno MIDI Interface from M-Audio for the 
VoiceQ machine. 

 

On the Mac running Pro Tools 

8. Launch Pro Tools application and select Pro Tools>Preferences… 
from the menu. 

9. Go to ‘Synchronization’ tab and check both ‘Machine Chases 
Memory Location’ and ‘Machine Follows Edit Insertion/Scrub’ 
checkboxes. 

 

 

10. Select Setup>Peripherals… from the menu to open the peripherals 
setup window. 

11. Go to ‘Synchronization’ tab and Select the MIDI interface 
connected to the machine for both MTC Reader and Generator ports. 
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12. Go to Machine Control tab and enable both Master and Slave, 
select the IAC Driver under the Master, and give the Master’s ID = 
120 so as not to cause a conflict when you Set ID of the Slave to 127. 

 

 

13. Select Setup>MIDI>MIDI Beat Clock… from the Pro Tools main menu 
to open the MIDI Beat Clock window. Enable MIDI Beat Clock and 
select the MIDI interface. 

 

 

14. In the Transport window or Synchronizations options via transport, 
select ‘GEN MTC’. Once activated both PT and VQ will be in sync. 
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On the Mac running VoiceQ 
 

1. Launch VoiceQ and select VoiceQ>Preferences… from VoiceQ 
main menu. 

 

 

2. Enable Output MMC Port and select the MIDI interface connected 
to the VoiceQ machine. 

3. Select the MIDI Chase Icon in the lower left hand corner of the VoiceQ 

Project window. 

 

 

VoiceQ will now chase the incoming MIDI timecode from Pro Tools 
through your hardware MIDI interface. 

 

VoiceQ will also scrub the video and scroll text in response to the MIDI 

machine control. MIDI Beat clock is used for additional synchronization 

accuracy. The transport controls in VoiceQ can also be used, even when 

VoiceQ is waiting for external MTC. To have VoiceQ chase incoming MTC 

from Pro Tools click on the `Chase External Timecode’ button in the transport 

section or use the Quick Key ⌘J. 
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Please contact VoiceQ Support if you require further information on how to 
implement any of these configurations. 

Thank you 

Your VoiceQ Support Team 
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